[uWSGI] nginx+uwsgi problem: Can't set empy SCRIPT_NAME param

Andrey Petrov shazow at gmail.com
Tue Jul 13 21:44:12 CEST 2010


Hi Roberto, sorry for not getting back.

I just tried to compile uwsgi from the latest hg tip, and I ran into this
error:

gcc -pthread -c -Wall -Werror -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
-I/usr/include/python2.6 -I/usr/include/python2.6 -DUWSGI_EMBEDDED
-DUWSGI_UDP -DUWSGI_ASYNC -DUWSGI_MULTICAST -DUWSGI_MINTERPRETERS
-DUWSGI_NAGIOS -DUWSGI_DEBUG -DUWSGI_PROXY -DUWSGI_EVDIS -DUWSGI_UGREEN
-DUWSGI_SNMP -DUWSGI_THREADING -DUWSGI_PROFILER -DUWSGI_PASTE
-DUWSGI_SENDFILE -I/usr/include/libxml2 -DUWSGI_XML -DUWSGI_XML_LIBXML2
-DUWSGI_PLUGIN_DIR=\".\" -DUWSGI_SPOOLER -DUWSGI_WSGI2 -DUWSGI_DEBUG -g -o
http.o http.c
gcc: http.c: No such file or directory
gcc: no input files
make: *** [all] Error 1


The same environment compiles the last stable version just fine.

Am I missing a new dependency or is there a bug in the tip?

- Andrey

On Tue, Jul 13, 2010 at 10:00 AM, Roberto De Ioris <roberto at unbit.it> wrote:

>
> Il giorno 07/lug/2010, alle ore 23.26, Andrey Petrov ha scritto:
>
> > Hi Roberto, thank you *very much* for your work! I'm very excited to try
> this. I'll let you know as soon as I do (hopefully this week).
> >
> > - Andrey
>
>
> Hi Andrey, some news on this ?
>
> A lot of users have asked for the backporting of a couple of 0.9.6 features
> (virtualhosting and the possibility to disable the internal SCRIPT_NAME
> routing) and i would like to add the new SCRIPT_NAME handling too.
>
> Thanks for your support
>
> --
> Roberto De Ioris
> http://unbit.it
> JID: roberto at jabber.unbit.it
>
> _______________________________________________
> uWSGI mailing list
> uWSGI at lists.unbit.it
> http://lists.unbit.it/cgi-bin/mailman/listinfo/uwsgi
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.unbit.it/pipermail/uwsgi/attachments/20100713/82f84d9c/attachment.htm 


More information about the uWSGI mailing list