[uWSGI] Cannot compile uWSGI in CentOS 5.5 x86_64

Michael Kang wxiluo at gmail.com
Fri Nov 12 02:29:35 CET 2010


Thank you very much!

It works.

On Thu, Nov 11, 2010 at 6:13 PM, Roberto De Ioris <roberto at unbit.it> wrote:
>
> Il giorno 11/nov/2010, alle ore 11.03, Michael Kang ha scritto:
>
>> Thank you for your reply. But I don't think it's right solution.
>>
>> I compiled python 2.6.6 as non-root user. ([mk at mk ]$ ./configure
>> --enable-shared --prefix=$HOME/py26) uWSGI should link to
>> $HOME/py26/bin/python2.6.
>>
>> There is python-devel in CentOS, but the version is 2.4.3.
>
> Edit uwsgiconfig.py and set PYLIB_PATH to the path of the lib directory
> this will even add the LD_RUN_PATH for the linker that will allow you to run uwsgi
> without specifying the LD_LIBARY_PATH
>
>
>
> --
> Roberto De Ioris
> http://unbit.it
>
> _______________________________________________
> uWSGI mailing list
> uWSGI at lists.unbit.it
> http://lists.unbit.it/cgi-bin/mailman/listinfo/uwsgi
>



-- 
Michael Kang(康上明学)
There is a giant asleep within every man. When the giant
awakens,miracles happen.

Personal Blog: http://ufusion.org - United Fusion


More information about the uWSGI mailing list