[uWSGI] got 500 when handling POST request with post-data

Roberto De Ioris roberto at unbit.it
Sat Oct 9 11:28:16 CEST 2010


>>
>> I respawn this thread as i have fixed another issue in the apache
>> module.
>>
>> You can get the updated version here:
>>
>> http://projects.unbit.it/uwsgi/browser/apache2/mod_uwsgi.c
>>
>> --
>> Roberto De Ioris
>> http://unbit.it
>> JID: roberto at jabber.unbit.it
>>
>
> After using this module, script returns {"foo": "bar"} and 500
> messages for every request with post body. Details are attached.
>
> $ wget -qO- --post-data='foo=bar'
> 'http://myhost.mydomain:18899/script/something'
> {"foo": "bar"}<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
> <html><head>
> <title>500 Internal Server Error</title>
> </head><body>
> <h1>Internal Server Error</h1>
> <p>The server encountered an internal error or
> misconfiguration and was unable to complete
> your request.</p>
> <p>Please contact the server administrator,
>  someone at somedomain.com and inform them of the time the error occurred,
> and anything you might have done that may have
> caused the error.</p>
> <p>More information about this error may be available
> in the server error log.</p>
> </body></html>
> _______________________________________________
> uWSGI mailing list
> uWSGI at lists.unbit.it
> http://lists.unbit.it/cgi-bin/mailman/listinfo/uwsgi
>

Please retry with the latest commit, i have explicity tested it with your
code (and it now handle gracefully socket RST)
-- 
Roberto De Ioris
http://unbit.it


More information about the uWSGI mailing list