[uWSGI] Newbie question about uwsgi/uWSGI + Lua

Roberto De Ioris roberto at unbit.it
Wed Apr 23 07:13:14 CEST 2014


> Thanks much for the help.
>
> Using the INI file below, uwsgi still...
>
> 1. doesn't support http://srv/ : I must type http://srv/index.html
> explicitely
>
> 2. http://srv/cgi/test.lua says "Not found", while http://srv/test.lua
> still shows the source code instead of running the script.
>
> ***************************
> [uwsgi]
> workdir = /tmp/uwsgi-2.0.3
> ipaddress = 192.168.0.10
>
> http = %(ipaddress):8080
> stats = %(ipaddress):9191
> processes = 4
> threads = 2
> uid=nobody
> gid=nogroup
> static-index = index.html,index.htm
> check-static=%(workdir)/www
> ;lua
> http-modifier1=9
> cgi=%(workdir)/cgi
> cgi-allowed-ext=.lua
> cgi-helper=.lua=lua
> ;run but don't send files ending in .lua
> static-skip-ext = .lua
> ***************************
>
> Also, when should I use http-modifier1? The doc only says: "You can
> use the http-modifier1 option to pass a custom modifier1 value to
> workers."
> http://uwsgi-docs.readthedocs.org/en/latest/HTTP.html
>
> Thank you.
>
> _______________________________________________
> uWSGI mailing list
> uWSGI at lists.unbit.it
> http://lists.unbit.it/cgi-bin/mailman/listinfo/uwsgi
>

I have added a commented snippet to the docs, it should help understanding
the setup:

https://github.com/unbit/uwsgi-docs/blob/master/Snippets.rst#full-stack-cgi-setup

-- 
Roberto De Ioris
http://unbit.it


More information about the uWSGI mailing list