[uWSGI] deploying a paste application (Allura)

Federico Bruni fede at inventati.org
Thu Jul 23 18:47:29 CEST 2015


Hi all

I'm trying to deploy for the first time an application with uwsgi.
The "Hello World!" example was successful :-)
Now I'm having problems with the real application I want to deploy (on 
my local machine first). It's quite urgent because it's a bug tracker 
for an open source project which is moving from Google Code and I have 
7 days left to make it work. I hope that you can help me and bare my 
ignorance.

There is probably something wrong in the way I call uwsgi, because the 
application cannot find the jinja2 template.

Everything runs within a virtualenv.
I tried these two commands:

uwsgi --ini-paste development.ini

uwsgi --paste config:/home/fede/www/allura-git/Allura/production.ini 
--http-socket :8080 -H /home/fede/.virtualenvs/allura

Both produce the same error.

And this is the [uwsgi] section in my .ini file:

[uwsgi]
socket = 127.0.0.1:8080
protocol = http
virtualenv = /home/fede/.virtualenvs/allura
chdir = /home/fede/www/allura-git/Allura
master = true
stats = 127.0.0.1:9191

which is basically this one:
https://forge-allura.apache.org/p/allura/git/ci/master/tree/Allura/development.ini

http protocol is not recommended, right? But it's the only one working 
in conjunction with nginx.

Thanks in advance
Federico





More information about the uWSGI mailing list