[uWSGI] uwsgi.chunked_read() - IOErrors

Roberto De Ioris roberto at unbit.it
Mon Nov 6 18:16:05 UTC 2017


> Hi,
>
> I’m having regular errors when using uWSGI’s uwsgi.chunked_read().  I am
> streaming the data through nginx to uWSGI using chunked transfer-encoding,
> then grabbing it in my flask app using chunked_read().
>
> It works perfectly most of the time, but sometimes I get the above
> mentioned error.  I’ve tried all kinds of things to eliminate the error
> but
> nothing I do will get rid of it.  I’ve tried adjusting the timeout,
> retrying the chunked_read in a loop with a wait, messing with any config
> option I can image, tuning the chunks buffer, recompiling uWSGI with
> different options, etc.
>
> Is this a known bug?  Or is it something that I’m missing?  Any help
> pointing me towards a solution would be greatly appreciated.

This generally means the user has closed the connection, adding
ignore-write-errors should disable the reporting.


>
> Also, it seems like uwsgi reading from that stream is somehow limiting the
> rate of the upload.  The data coming into NGINX will go at 50-80MB/sec,
> but
> I can't get UWSGI to go much above 30.   Even when I'm just reading the
> data from the stream and throwing it out.
>
> Thanks in advance!!!
>
>

This is pretty strange, how uWSGI is connected to nginx ? (unix or tcp
sockets ?)

-- 
Roberto De Ioris
http://unbit.com


More information about the uWSGI mailing list