[uWSGI] php plugin ends with sapi global error, no start (SOLVED)

Krzysztof Warzecha kwarzecha7 at gmail.com
Wed Feb 6 21:27:29 UTC 2019


Hi,

Glad you got that working.


> However, it is for me still a riddle, why the result of "ldd
> php71_plugin.so" pointed to the wrong library.

I cannot comment on that as I don't know yet where it pointed :).
Could you post output from "ldd php71_plugin.so | grep php"?

Right now I can make few assumptions and hopefully point you in the
right direction.


>> 1 - download php and build it with: ./configure
>> --prefix=/usr/local/php71-emb --enable-mbstring --enable-embed

Which release of php have you downloaded? Current git master produces
libphp8.so. I'm assuming you've downloaded php71 release.


>> make, and make install.

Where did that put libphp7.so? Somewhere near
/usr/local/php71-emb/lib/libphp7.so, right? When starting uwsgi, are
you using --dlopen /usr/lib/libphp7.1.so (Debian's libphp-embed) or
--dlopen /usr/local/php71-emb/lib/libphp7.so (built from source)?

-- 
Krzysztof Warzecha


More information about the uWSGI mailing list